System.IO.FileLoadException

Aug 29, 2010 at 5:13 PM
Edited Aug 31, 2010 at 1:12 PM

Hi,

i would love to use this control, but i cannot manage to get it working.

I have done the following steps:

  1. I downloaded the source (Change Set 48188) and compiled it in VS 2008. (Release mode)
  2. I created a new WPF project in VS 2010, added references to the Cjc.AwesomiumWrapper.dll and the Cjc.ChromiumBrowser.dll
  3. I downloaded the latest beta of Awesomium (1.6 Beta B) and copied the contents of the /bin/debug directory to the project's /Bin/Debug directory. (I've tried the release versions, too)
  4. I used the following XAML code:

 

<Window x:Class="MainWindow"
xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
xmlns:c="clr-namespace:Cjc.ChromiumBrowser;assembly=Cjc.ChromiumBrowser"
Title="MainWindow" Height="350" Width="525" >
<Grid>
<c:WebBrowser>
</c:WebBrowser>
</Grid>
</Window>

 

At the moment I typed in the <c:WebBrowser> thing, the designer came up with this error: (german Visual Studio; translation underneath)

System.IO.FileLoadException
Die Datei oder Assembly "Cjc.AwesomiumWrapper.dll" oder eine Abhängigkeit davon wurde nicht gefunden. Unbekannter Fehler (Ausnahme von HRESULT: 0x80004005 (E_FAIL))

Translation:

System.IO.FileLoadException
The file or assembly "Cjc.AwesomiumWrapper.dll" or any of it's dependencies couldn't be found. Unknown error (exception from HRESULT: 0x80004005 (E_FAIL))

Start debugging raises the same error.

Can anyone say how to get this working?

Regards,

SeriTools (Dennis Duda)

EDIT: I compiled the DLL's with VS 2010, but the error still remains. I also tried to change the Awesomium.lib to the new version of 1.6 beta B, but there come only "external symbol not found" errors

Aug 31, 2010 at 7:55 AM

Hi, did you solve the problem? I have exactly the same problem, but I am using VS 2010. The problem seems only affect the Visual Designer of the VS, when I build and run the project, it works well. Did you find a solution?

Aug 31, 2010 at 12:28 PM

Hi,

no, i couldn't solve the problem. And I forgot to add that I use VS 2010, too.

But it confuses me that it it working in a compiled version. I get the same error if I try to start debugging the project...

Regards,

SeriTools (Dennis Duda)

Coordinator
Aug 31, 2010 at 1:19 PM

superfishkid & SeriTools - Sorry for my slow reply.  The 48188 changeset is actually based on Awesomium 1.5.1 rather than 1.6 beta.  If you're wanting to use Awesomium 1.6 beta, currently you can get the code from the 'Downloads' section (http://wpfchromium.codeplex.com/releases/view/49484).  Please note there are a couple bugs left in Awesomium that should be fixed in the coming weeks (v1.6 release is imminent).

Currently the most stable WebBrowser/Awesomium combo is in the original demo ClickOnce app.  You could try the old binaries here: http://www.chriscavanagh.com/chris/Cjc.ThreeDeemium/Cjc.ChromiumBrowserDemo.zip.

I'll update here as soon as the v1.6-based version is ready (fingers crossed, real soon now).